Download Game! Currently 91 players and visitors. Last logged in:ElwynesUrsaAxlHallu

BatMUD Forums > Batclient > Re: Fix for settings not saving

 
 
#1
13 May 2021 14:42
 
 
Create the following files in '/conf' in batclients settings folder
($HOME/batclient in linux and macos, C:\Documents and
Settings\%username%\batclient\ i think in windows).

actionbuttons.xml
aliases.xml
config.xml
desktop.xml
keybinding.xml
macros.xml
triggers.xml

Then make sure each file the following content:
<?xml version="1.0" encoding="ISO-8859-1"?>
<Filename />

so <Aliases /> in aliases.xml and so on.
except actionbuttons.xml which is <ActionButtonConfig /> because
consistency is for suckers.
If you're having problems with the EULA agreement window put the following in
config.xml
<Config>
<EULA accepted="true" />
</Config>

 
Rating:
1
Votes:
1
 
 
Nap
164d, 12h, 12m, 43s old
Level:
90
 
 
#2
13 May 2021 22:03
 
 
Hilites made with the /hilite command still don't seem to save, make sure to
use triggers.

 
Rating:
1
Votes:
1
 
 
Nap
164d, 19h, 29m, 8s old
Level:
90
 
 
#3
14 May 2021 20:06
 
 
Hi,

Really appreciate taking the time to provide these steps.
I have followed them but they did not fix the problem.
I have created the files you mentioned in:
C:\Users\<myusername>\batclient\conf
I have added the file contents like:
<?xml version="1.0" encoding="ISO-8859-1"?>
<Aliases />
except for Actionbuttons for which I added:
<?xml version="1.0" encoding="ISO-8859-1"?>
<ActionButtonConfig />

I noticed my Config file is empty, but I added:
<Config>
<EULA accepted="true" />
</Config>

After all the steps, the settings still do not save after I Esc > Quit.
If I did something wrong or I missed anything, I would appreciate some help.

Thank you.

 
Rating:
1
Votes:
1
 
 
 
 
#4
14 May 2021 23:53
 
 
Hey, unfortunately I just don't know why it didn't work for you.
Maybe I got the windows folder wrong? Perhaps someone who has a working client
on windows could confirm.

 
 
 
Nap
165d, 8h, 18m, 11s old
Level:
90